summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-07-23 17:39:37 -0400
committerOwain G. Ainsworth <oga@openbsd.org>2010-09-12 03:34:02 +0100
commita9eb882c1738ac57875cf31a957306500178c1a7 (patch)
tree6beaa0a3db8c9df1618041c4a55bca52486d61d9 /configure.ac
parent8af366d7eba7de7f15aeb25ebe3bd84aa261faaa (diff)
simplify Makefile as per-target compilation flags are not needed
Per-target compilation flags (libIntelXvMC_la_CFLAGS) are required when multiple targets which require different compiler flags, are build in the same makefile. Automake issues a command with -c and -o flags which not all compilers support. The object fles are prefixed with libIntelXvMC_la. The macro AM_PROG_CC_C_O must then be used to provide this feature on compilers that do not have it. If not, a warning is issued at make time. This macros checks for compiler support and if missing, uses a "compile" script it generates in the package root directory. Currently the driver uses per-target flags but the macro is missing. Rather than adding the macro, this patch stops using per-target flags by using the AM_CFLAGS variable for all targets in the makefile, as there is only one. Acked-by: Chris Wilson <chris@chris-wilson.co.uk> Signed-off-by: Gaetan Nadon <memsize@videotron.ca> (cherry picked from commit 68df6b2790891683ee2e58daaad34ef17ae344f5) Signed-off-by: Owain G. Ainsworth <oga@openbsd.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1b0137f8..c8f88950 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,6 @@ XORG_DEFAULT_OPTIONS
# Initialize libtool
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
-AM_PROG_CC_C_O
PKG_CHECK_MODULES(GEN4ASM, [intel-gen4asm >= 1.0], [gen4asm=yes], [gen4asm=no])
AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)