summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-07-03 19:33:55 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-07-03 20:08:02 +0100
commit9e2ac8a413c05aafd1c69775c5b0fa5f1f37ac23 (patch)
tree98bc37ba19a791a7bcc41ddbe78edb97e93c12fb /configure.ac
parentf26163e916e21f6b64a19c147165f2f2c9c5466d (diff)
sna: Use set-cache-level ioctl to create CPU bo
As an alternative to vmap, we can use the kernel for all memory management through bo, which is much preferred for its simplicity (i.e. avoiding introducing even more vm complexity). Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 604db7de..d1ddf955 100644
--- a/configure.ac
+++ b/configure.ac
@@ -205,6 +205,16 @@ if test "x$accel" = xno; then
AC_MSG_ERROR([No default acceleration option])
fi
+AC_ARG_ENABLE(cache-level,
+ AS_HELP_STRING([--enable-cache-level],
+ [Enable use of cache level ioctl (experimental) [default=no]]),
+ [CACHE_LEVEL="$enableval"],
+ [CACHE_LEVEL=no])
+AM_CONDITIONAL(USE_CACHE_LEVEL, test x$CACHE_LEVEL = xyes)
+if test "x$CACHE_LEVEL" = xyes; then
+ AC_DEFINE(USE_CACHE_LEVEL,1,[Assume DRM_I915_GEM_SET_CACHE_LEVEL_IOCTL support])
+fi
+
AC_ARG_ENABLE(vmap,
AS_HELP_STRING([--enable-vmap],
[Enable use of vmap (experimental) [default=no]]),