summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJesse Barnes <jbarnes@virtuousgeek.org>2009-05-15 08:50:17 -0700
committerJesse Barnes <jbarnes@virtuousgeek.org>2009-05-15 08:50:17 -0700
commitebe05200df381c0e6ee636f0f83440bfedea9bcb (patch)
treef2d6232014465fb80907bd2258c3a4509393cb0e /configure.ac
parent04772b6c09a88f0483c2a7efc48029967c77b9bc (diff)
Add --enable-debug flag to configure
Defaults to enabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 028d17d3..bb05d1e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,6 +70,14 @@ AC_ARG_ENABLE(video-debug, AC_HELP_STRING([--enable-video-debug],
[VIDEO_DEBUG="$enableval"],
[VIDEO_DEBUG=no])
+AC_ARG_ENABLE(debug, AC_HELP_STRING([--enable-debug],
+ [Compile with debug support [[default=yes]]]))
+if test "x$enableval" == "xyes" ; then
+ DEBUGFLAGS="-g"
+else
+ DEBUGFLAGS=""
+fi
+
dnl AC_ARG_ENABLE(xvmc, AC_HELP_STRING([--disable-xvmc],
dnl [Disable XvMC support [[default=auto]]]),
dnl [XVMC="$enableval"],
@@ -116,7 +124,7 @@ if test x$DRI = xauto; then
fi
fi
AC_MSG_RESULT([$DRI])
-CFLAGS="$save_CFLAGS"
+CFLAGS="$save_CFLAGS $DEBUGFLAGS"
PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.10])