summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2006-06-26 15:06:42 +0200
committerEric Anholt <anholt@FreeBSD.org>2006-06-26 15:06:42 +0200
commit21dc3edfc41987bb8cf0f8d265fba9775cbe8cdb (patch)
treecc9b422fd0cd41db3e88a723cbe1397851c80aff /configure.ac
parentf113e9002cf53510e30984f816d44b06f1e71216 (diff)
parent5111b883480a5a9cc82200f2684cba67b515aa73 (diff)
Merge branch 'master' into modesetting
Conflicts: src/i830.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 12 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 34672969..deb99c21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,10 +39,6 @@ AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_PROG_CC
-if test "x$GCC" = "xyes"; then
- CFLAGS="$CFLAGS -Wall"
-fi
-
AH_TOP([#include "xorg-server.h"])
AC_ARG_WITH(xorg-module-dir,
@@ -93,6 +89,18 @@ if test x$DRI = xauto; then
fi
AC_MSG_RESULT([$DRI])
+dnl Use lots of warning flags with GCC
+
+WARN_CFLAGS=""
+
+if test "x$GCC" = "xyes"; then
+ WARN_CFLAGS="-Wall -Wpointer-arith -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations \
+ -Wnested-externs -fno-strict-aliasing"
+fi
+
+CFLAGS="$CFLAGS $WARN_CFLAGS"
+
AM_CONDITIONAL(DRI, test x$DRI = xyes)
if test "$DRI" = yes; then
PKG_CHECK_MODULES(DRI, [libdrm >= 2.0 xf86driproto])