summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJulien Cristau <jcristau@debian.org>2008-01-24 15:24:40 +0100
committerJulien Cristau <jcristau@debian.org>2008-01-24 15:24:40 +0100
commit94a18fa1f8141837bdab32e545da7a7aed1cc396 (patch)
treef1ee0d4ea3e0bd48f7e98d144727eb18416dfabf /configure.ac
parentd341e41c863f1212bf2c6b84782a7e472b6612a1 (diff)
Don't build reg_dumper if we don't have pciaccess 0.10.0
The pci_device_map_range() function was added in libpciaccess 0.10.0, and is used by the reg_dumper tool. Don't try to build it if we have an older libpciaccess. Also make sure that util-macros >= 1.1.3 is available when running autoconf, because it's required for the PACKAGE_VERSION_* macros.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 334a1f49..e707a1a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,7 +117,7 @@ CFLAGS="$save_CFLAGS"
if test x$XSERVER_LIBPCIACCESS = xyes; then
PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.10.0])
else
- PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.5.0],
+ PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.10.0],
have_libpciaccess=yes,
have_libpciaccess=no)
fi
@@ -216,6 +216,8 @@ AC_SUBST([moduledir])
DRIVER_NAME=intel
AC_SUBST([DRIVER_NAME])
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.1.3)
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION