summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Menzel <paulepanter@users.sourceforge.net>2013-02-02 11:44:54 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-02-03 09:26:08 +0000
commit9640640ab02d5de630e903116c1b104752f8b604 (patch)
treeb3de022b0b0f0ea487b7a79703e4b25a44ca9cce /configure.ac
parent9807bba950078d86a25b91064ecfebaa0ee459e3 (diff)
configure.ac: Do not include `xext` and `xfixes` in `XVMCLIB`
Building the package under Debian Sid/unstable, `dh_shlibdeps` informs that `libIntelXvMC.so.1.0.0` does not need to be linked against `libXext.so.6` or `libXfixes.so.3` [1]. $ debuild -b -us -uc […] make[1]: Entering directory `/build/buildd-xserver-xorg-video-intel_2.19.0-6-i386-9thLfo/xserver-xorg-video-intel-2.19.0' dh_shlibdeps -- --warnings=6 dpkg-shlibdeps: warning: debian/xserver-xorg-video-intel/usr/lib/libIntelXvMC.so.1.0.0 should not be linked against libXext.so.6 (it uses none of the library's symbols) dpkg-shlibdeps: warning: debian/xserver-xorg-video-intel/usr/lib/libIntelXvMC.so.1.0.0 should not be linked against libXfixes.so.3 (it uses none of the library's symbols) dpkg-shlibdeps: warning: debian/xserver-xorg-video-intel/usr/lib/libI810XvMC.so.1.0.0 should not be linked against libXext.so.6 (it uses none of the library's symbols) dpkg-shlibdeps: warning: debian/xserver-xorg-video-intel/usr/lib/libI810XvMC.so.1.0.0 should not be linked against libXfixes.so.3 (it uses none of the library's symbols) dpkg-shlibdeps: warning: debian/xserver-xorg-video-intel/usr/lib/libI810XvMC.so.1.0.0 should not be linked against libX11-xcb.so.1 (it uses none of the library's symbols) dpkg-shlibdeps: warning: debian/xserver-xorg-video-intel/usr/lib/libI810XvMC.so.1.0.0 should not be linked against libxcb-dri2.so.0 (it uses none of the library's symbols) dpkg-shlibdeps: warning: debian/xserver-xorg-video-intel/usr/lib/libI810XvMC.so.1.0.0 should not be linked against libxcb-util.so.0 (it uses none of the library's symbols) dpkg-shlibdeps: warning: debian/xserver-xorg-video-intel/usr/lib/libI810XvMC.so.1.0.0 should not be linked against libxcb.so.1 (it uses none of the library's symbols) dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/xserver-xorg-video-intel/usr/lib/libIntelXvMC.so.1.0.0 debian/xserver-xorg-video-intel/usr/lib/libI810XvMC.so.1.0.0 were not linked against libXext.so.6 (they use none of the library's symbols) dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/xserver-xorg-video-intel/usr/lib/libIntelXvMC.so.1.0.0 debian/xserver-xorg-video-intel/usr/lib/libI810XvMC.so.1.0.0 were not linked against libXfixes.so.3 (they use none of the library's symbols) make[1]: Leaving directory `/build/buildd-xserver-xorg-video-intel_2.19.0-6-i386-9thLfo/xserver-xorg-video-intel-2.19.0' dh_installdeb -a -O--builddirectory=build/ […] Not populating `XVMCLIB` with `xext` and `xfixes` makes the warning go away and the libraries are still built without any issues. [1] https://buildd.debian.org/status/fetch.php?pkg=xserver-xorg-video-intel&arch=i386&ver=2%3A2.19.0-6&stamp=1347825458 Signed-off-by: Paul Menzel <paulepanter@users.sourceforge.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5135ecce..e6ab9d0e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -404,7 +404,7 @@ AC_MSG_RESULT([$DRI2])
if test "$XVMC" = yes; then
PKG_CHECK_MODULES(XVMCLIB,
- [xvmc xext xfixes dri2proto x11-xcb xcb-dri2 xcb-aux],
+ [xvmc dri2proto x11-xcb xcb-dri2 xcb-aux],
[XVMC=yes], [XVMC=no])
fi
AC_MSG_CHECKING([whether to include XvMC support])