summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThierry Reding <thierry.reding@avionic-design.de>2012-03-15 13:10:20 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-03-15 12:42:46 +0000
commit64ccc6698def517fc37e9ba3c41715626df0e3ca (patch)
tree3dae518c7afda5229a3cb9b97a371ff9d57265f3 /configure.ac
parentc5c61ef378cad3c8259631138ea1e03eb02036af (diff)
configure: Keep passed-in CFLAGS for DRI tests
When the user passes extra CFLAGS and CPPFLAGS to the configure script, they should be kept when performing subsequent checks with additional flags. This is required to properly build in cross-compilation setups where the user may pass in flags like --sysroot in order to pick up the cross-built dependencies. Signed-off-by: Thierry Reding <thierry.reding@avionic-design.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 03a35bdf..7ca3075c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -192,8 +192,8 @@ sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`
if test "x$enable_dri" != "xno"; then
save_CFLAGS="$CFLAGS"
save_CPPFLAGS="$CPPFLAGS"
- CFLAGS="$XORG_CFLAGS $DRI_CFLAGS $DRM_CFLAGS"
- CPPFLAGS="$XORG_CFLAGS $DRI_CFLAGS $DRM_CFLAGS"
+ CFLAGS="$CFLAGS $XORG_CFLAGS $DRI_CFLAGS $DRM_CFLAGS"
+ CPPFLAGS="$CPPFLAGS $XORG_CFLAGS $DRI_CFLAGS $DRM_CFLAGS"
AC_CHECK_HEADERS([dri.h sarea.h dristruct.h],, [DRI=no],
[/* for dri.h */
#include <xf86str.h>