summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-07-21 12:51:41 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-07-21 12:53:34 +0100
commit83ad661bc73e9d0094b669c5203e25afc3937bb7 (patch)
tree6df6fd35b1d304761762dc03acf251bf1d60d8f4 /configure.ac
parent8dcccd308222bcf1b96f2ee15842b4558ea5f29e (diff)
sna: Change the vmap interface name to userptr
This is in common with the other drivers and avoids the conflict with 'vmalloc/vmap' used by the kernel for allocation of contiguous virtual mappings. Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index b3a786d7..45157a8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -247,14 +247,14 @@ if test "x$accel" = xno; then
AC_MSG_ERROR([No default acceleration option])
fi
-AC_ARG_ENABLE(vmap,
- AS_HELP_STRING([--enable-vmap],
- [Enable use of vmap (experimental) [default=no]]),
- [VMAP="$enableval"],
- [VMAP=no])
-AM_CONDITIONAL(USE_VMAP, test x$VMAP = xyes)
-if test "x$VMAP" = xyes; then
- AC_DEFINE(USE_VMAP,1,[Assume VMAP support])
+AC_ARG_ENABLE(userptr,
+ AS_HELP_STRING([--enable-userptr],
+ [Enable use of userptr (experimental) [default=no]]),
+ [USERPTR="$enableval"],
+ [USERPTR=no])
+AM_CONDITIONAL(USE_USERPTR, test x$USERPTR = xyes)
+if test "x$USERPTR" = xyes; then
+ AC_DEFINE(USE_USERPTR,1,[Assume USERPTR support])
fi
AC_ARG_ENABLE(async-swap,