summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-07-14 13:05:27 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-07-14 14:15:11 +0100
commit95fdd9af5c8a8360d02debc400e75869c36f05ca (patch)
treef2aba50030905a690983f22b89ae17c4644c1126 /configure.ac
parent3f764ee4c50567cfb831495d42cb6c2bb94055ad (diff)
sna: Enable pixman_glyphs if available
Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d323da7f..8cbbbc13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,10 @@ AC_ARG_ENABLE(kms-only, AS_HELP_STRING([--enable-kms-only],
required_xorg_xserver_version=1.6
required_pixman_version=0.24
+if pkg-config --exists 'pixman-1 >= 0.27.1'; then
+ AC_DEFINE([HAS_PIXMAN_GLYPHS], 1, [Enable pixman glyph cache])
+fi
+
AC_ARG_ENABLE(sna,
AS_HELP_STRING([--enable-sna],
[Enable SandyBridge's New Acceleration (SNA) [default=auto]]),