summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2006-09-01 16:47:17 -0700
committerEric Anholt <eric@anholt.net>2006-09-01 16:47:17 -0700
commit1e6e288b8826789f3b2520d12426ff7852a67ccd (patch)
treefd129aaac4b418f11ec56c94171f4c6fec692bde /configure.ac
parent1feb733eb8b09a8b07b7a6987add5149c53b0157 (diff)
Add a check for intel-gen4asm, and rules to compile {wm,sf}_prog.h using it.
This adds assembly source for the two programs used in the textured video implementation on the 965, which should make them easier to modify in the future. The compiled versions are also included, so that intel-gen4asm isn't a build requirement for people that aren't modifying these programs. There are minor differences in the compiled versions of these programs compared to their previous versions which were compiled with a different tool. I believe the changes should be harmless, and video continues to work on my system.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 436d7e5c..a27822e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,6 +49,9 @@ AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_PROG_CC
+AC_CHECK_PROG(gen4asm, [intel-gen4asm], yes, no)
+AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)
+
AH_TOP([#include "xorg-server.h"])
AC_ARG_WITH(xorg-module-dir,