summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZhenyu Wang <zhenyu.z.wang@intel.com>2007-12-20 13:39:32 +0800
committerZhenyu Wang <zhenyu.z.wang@intel.com>2007-12-20 13:39:32 +0800
commit216ad7398742f2f80b5477e89f827acb351b4d72 (patch)
treea44b78e1ebd5c60fe3ba34e6b87c512e9fb0ea8c /configure.ac
parenta811ca30659e8c477027ea9c91fb9fc516fdabc7 (diff)
xvmc: add disable xvmc build support
Move xvmc source files under XVMC config
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 334a1f49..b46b97aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,6 +66,10 @@ AC_ARG_WITH(xserver-source,AC_HELP_STRING([--with-xserver-source=XSERVER_SOURCE]
[ XSERVER_SOURCE="$withval" ],
[ XSERVER_SOURCE="" ])
+AC_ARG_ENABLE(xvmc, AC_HELP_STRING([--disable-xvmc],
+ [Disable XvMC support [[default=yes]]]),
+ [XVMC="$enableval"],
+ [XVMC=yes])
# Checks for extensions
XORG_DRIVER_CHECK_EXT(XINERAMA, xineramaproto)
@@ -208,6 +212,14 @@ if test "$VIDEO_DEBUG" = yes; then
AC_DEFINE(VIDEO_DEBUG,1,[Enable debug support])
fi
+AC_MSG_CHECKING([whether to include XvMC support])
+AC_MSG_RESULT([$XVMC])
+AM_CONDITIONAL(XVMC, test x$XVMC = xyes)
+if test "$XVMC" = yes; then
+ AC_DEFINE(ENABLE_XVMC,1,[Enable XvMC support])
+fi
+
+
AC_SUBST([DRI_CFLAGS])
AC_SUBST([XORG_CFLAGS])
AC_SUBST([WARN_CFLAGS])