summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2008-04-17 10:04:55 -0700
committerKeith Packard <keithp@keithp.com>2008-04-17 10:05:00 -0700
commitc3fb62df4e60b63295f94c99b3c5de70dbf94e1c (patch)
tree8130adeb7e0c6631ead77bfb0258fd8c3fff7e1a /configure.ac
parent0ae283582d21776d3317d5fc1c25751d50d562c7 (diff)
Add a kludge-around to fix cd/wt bits in fb ptes on linux.
Mmap from /sys/devices/pci* on linux forces the cache-disable and write-through bits, which turns our write-combining map into an uncached-map, seriously impacting performance. It turns out that a bug in mprotect allows us to fix this by disabling access to those pages and then immediately re-enabling them.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f203d658..c0a1e0bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,9 @@ AM_PROG_CC_C_O
AC_CHECK_PROG(gen4asm, [intel-gen4asm], yes, no)
AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)
+AC_CHECK_HEADERS(sys/mman.h)
+AC_CHECK_FUNCS(mprotect)
+
AH_TOP([#include "xorg-server.h"])
AC_ARG_WITH(xorg-module-dir,