summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2008-04-29 10:32:14 -0700
committerKeith Packard <keithp@keithp.com>2008-04-29 10:32:14 -0700
commitfff17b9d1b58cb53032d153094826dd306836d59 (patch)
tree4a5767639ba38dacd4c37d627543878e24ea18eb /configure.ac
parent1d467a8038946a37844795e8860be113d43219ac (diff)
Use new xf86RotateFreeShadow function to clean up shadow buffers.
This simply moves code from the driver up into the X server; use it where available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c0a1e0bc..00f075e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -174,6 +174,18 @@ fi
AC_SUBST([XMODES_CFLAGS])
+SAVE_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
+
+AC_CHECK_DECL(xf86RotateFreeShadow,
+ [AC_DEFINE(HAVE_FREE_SHADOW, 1, [have new FreeShadow API])],
+ [],
+ [#include <xorg-server.h>
+ #include <windowstr.h>
+ #include <xf86Crtc.h>])
+
+CPPFLAGS="$SAVE_CPPFLAGS"
+
dnl Use lots of warning flags with GCC
WARN_CFLAGS=""