summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJulien Cristau <jcristau@debian.org>2008-06-06 13:40:20 +0200
committerZhenyu Wang <zhenyu.z.wang@intel.com>2008-07-21 11:13:19 +0800
commit0a7b753d70e1fd494430c496e19fb672258b5ac6 (patch)
treee41e69a33138d73dcdfeabde9f31d54ad477ab98 /src/Makefile.am
parentb27776f498c23787629a229f5d9c07eb3b383333 (diff)
Link the driver with -lpciaccess and -ldrm if needed
This makes sure the driver ends up with a DT_NEEDED reference to the libraries it's using. (cherry picked from commit 8ac00ca97995e36514ff593fec3c0f0d316ed138)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 45f8b19a..1e4ad28c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,6 +36,10 @@ AM_CFLAGS = @WARN_CFLAGS@ @XORG_CFLAGS@ @DRI_CFLAGS@ @PCIACCESS_CFLAGS@ \
intel_drv_la_LTLIBRARIES = intel_drv.la
intel_drv_la_LDFLAGS = -module -avoid-version
intel_drv_ladir = @moduledir@/drivers
+intel_drv_la_LIBADD =
+if XSERVER_LIBPCIACCESS
+intel_drv_la_LIBADD += @PCIACCESS_LIBS@
+endif
XMODE_SRCS=\
local_xf86Rename.h \
@@ -203,6 +207,8 @@ endif
if DRI
intel_drv_la_SOURCES += \
$(INTEL_DRI_SRCS)
+intel_drv_la_LIBADD += \
+ $(DRI_LIBS)
endif
if XVMC