summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@neko.keithp.com>2007-02-01 22:48:44 -0800
committerKeith Packard <keithp@neko.keithp.com>2007-02-01 22:48:44 -0800
commit785a59ead0e8d1d681b2cb6827ee58ad2c51f8c6 (patch)
treed9bcd7dc81d2065f2434deb97d5c50bab79ea057 /src/Makefile.am
parent1dde7a15a3a42b881c57ece95feceffadf412cff (diff)
Rename driver from i810 to intel. Permit old name for compatibility.modesetting-rotation
Driver installs as intel_drv.so with symlink to i810_drv.so to ensure existing configurations continue to work. Updated manual page to reflect name change and add attributions for recent work.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am17
1 files changed, 12 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 7656e02e..f824a747 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -28,11 +28,11 @@ SUBDIRS = xvmc bios_reader ch7017 ch7xxx ivch sil164
AM_CFLAGS = @WARN_CFLAGS@ @XORG_CFLAGS@ @DRI_CFLAGS@ \
-DI830_XV -DI830_USE_XAA -DI830_USE_EXA
-i810_drv_la_LTLIBRARIES = i810_drv.la
-i810_drv_la_LDFLAGS = -module -avoid-version
-i810_drv_ladir = @moduledir@/drivers
+intel_drv_la_LTLIBRARIES = intel_drv.la
+intel_drv_la_LDFLAGS = -module -avoid-version
+intel_drv_ladir = @moduledir@/drivers
-i810_drv_la_SOURCES = \
+intel_drv_la_SOURCES = \
brw_defines.h \
brw_structs.h \
sf_prog.h \
@@ -112,7 +112,7 @@ exa_wm_masknoca_prog.h: exa_wm_masknoca.g4a
endif
if DRI
-i810_drv_la_SOURCES += \
+intel_drv_la_SOURCES += \
i810_dri.c \
i810_dri.h \
i830_dri.c \
@@ -123,3 +123,10 @@ endif
EXTRA_DIST = \
packed_yuv_sf.g4a \
packed_yuv_wm.g4a
+
+install-data-local: install-intel_drv_laLTLIBRARIES
+ (cd $(DESTDIR)$(intel_drv_ladir) && rm -f i810_drv.so && ln -s intel_drv.so i810_drv.so)
+
+uninstall-local:
+ (cd $(DESTDIR)$(intel_drv_ladir) && rm -f i810_drv.so)
+