summaryrefslogtreecommitdiff
path: root/src/ivch/Makefile.am
diff options
context:
space:
mode:
authorKeith Packard <keithp@neko.keithp.com>2007-04-19 13:15:23 -0700
committerKeith Packard <keithp@neko.keithp.com>2007-04-19 13:15:23 -0700
commitcca389769001c657435f056e1f1c26b0f52a48bd (patch)
tree8ce6b6f001d4bf32dd25a122c1a015ef34496cad /src/ivch/Makefile.am
parent07797fee88d6be0dfb30394a419dd86f8a3c9095 (diff)
Clean up 1.2 xserver build support.
Convert relative X server source path to absolute. Check for local copies of needed header files before building, rather than requiring server source. Remove extra duplicate -I elements in AM_CFLAGS in sub directories.
Diffstat (limited to 'src/ivch/Makefile.am')
-rw-r--r--src/ivch/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/ivch/Makefile.am b/src/ivch/Makefile.am
index cf05c018..1dc9cb35 100644
--- a/src/ivch/Makefile.am
+++ b/src/ivch/Makefile.am
@@ -3,8 +3,7 @@
# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
-AM_CFLAGS = @WARN_CFLAGS@ @XMODES_CFLAGS@ @XORG_CFLAGS@ @DRI_CFLAGS@ \
- -I$(srcdir)/.. -I$(srcdir)/../modes
+AM_CFLAGS = @WARN_CFLAGS@ @XMODES_CFLAGS@ @XORG_CFLAGS@ @DRI_CFLAGS@
ivch_la_LTLIBRARIES = ivch.la
ivch_la_LDFLAGS = -module -avoid-version