summaryrefslogtreecommitdiff
path: root/src/render_program/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2012-10-07 10:46:19 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2012-10-07 10:49:07 +0100
commit4d2dba0ba70c2b217a777243e8a89f7a5c5349a9 (patch)
tree7014d9ec082fa4e166d266253c8ff8946e0c6a5e /src/render_program/Makefile.am
parent249051d90fb0ab0bea5561a04ee2a5d0a2238ff1 (diff)
Use path for intel-gen4asm derived from pkg-config
As we use pkg-config to determine whether to use intel-gen4asm, we should also use it to locate the right version of intel-gen4asm to use. This allows the user to install the assembler in a non-standard path for cross-builds and similar. Reported-by: Josh Tripplet <josh@freedesktop.org> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=55646 Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'src/render_program/Makefile.am')
-rw-r--r--src/render_program/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/render_program/Makefile.am b/src/render_program/Makefile.am
index 1704036c..8b82b2e0 100644
--- a/src/render_program/Makefile.am
+++ b/src/render_program/Makefile.am
@@ -191,16 +191,16 @@ if HAVE_GEN4ASM
SUFFIXES = .g4a .g4b .g5a .g5b .g6a .g6b .g7a .g7b
.g4a.g4b:
- m4 -I$(srcdir) -s $< > $*.g4m && intel-gen4asm -o $@ $*.g4m && intel-gen4asm -g 5 -o $@.gen5 $*.g4m && rm $*.g4m
+ m4 -I$(srcdir) -s $< > $*.g4m && @INTEL_GEN4ASM@ -o $@ $*.g4m && @INTEL_GEN4ASM@ -g 5 -o $@.gen5 $*.g4m && rm $*.g4m
.g5a.g5b:
- m4 -I$(srcdir) -s $< > $*.g5m && intel-gen4asm -g 5 -o $@ $*.g5m && rm $*.g5m
+ m4 -I$(srcdir) -s $< > $*.g5m && @INTEL_GEN4ASM@ -g 5 -o $@ $*.g5m && rm $*.g5m
.g6a.g6b:
- m4 -I$(srcdir) -s $< > $*.g6m && intel-gen4asm -g 6 -o $@ $*.g6m && rm $*.g6m
+ m4 -I$(srcdir) -s $< > $*.g6m && @INTEL_GEN4ASM@ -g 6 -o $@ $*.g6m && rm $*.g6m
.g7a.g7b:
- m4 -I$(srcdir) -s $< > $*.g7m && intel-gen4asm -g 7 -o $@ $*.g7m && rm $*.g7m
+ m4 -I$(srcdir) -s $< > $*.g7m && @INTEL_GEN4ASM@ -g 7 -o $@ $*.g7m && rm $*.g7m
$(INTEL_G4B): $(INTEL_G4I)
$(INTEL_G5B): $(INTEL_G4I)