summaryrefslogtreecommitdiff
path: root/src/uxa/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2013-07-26 10:19:43 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2013-07-28 14:49:07 +0100
commit04d5c33b9677fc920ad58522f93d832a42de4744 (patch)
tree9d70a4068c0d171fa2418985532045185bc5a17b /src/uxa/Makefile.am
parent45d4e8dcf9aee37015b1ee026997ed4dabdf112e (diff)
uxa: Colocate architecture source files with backend implementation sources
i.e. move the toplevel uxa/*.[ch] into src/uxa/*.[ch] Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Diffstat (limited to 'src/uxa/Makefile.am')
-rw-r--r--src/uxa/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/uxa/Makefile.am b/src/uxa/Makefile.am
index 5f89cfc2..945d7d42 100644
--- a/src/uxa/Makefile.am
+++ b/src/uxa/Makefile.am
@@ -23,7 +23,7 @@ AM_CFLAGS += @UDEV_CFLAGS@ @DRM_CFLAGS@ @DRMINTEL_CFLAGS@
AM_CFLAGS += -I$(top_srcdir)/uxa -I$(top_srcdir)/src -I$(top_srcdir)/src/render_program
noinst_LTLIBRARIES = libuxa.la
-libuxa_la_LIBADD = @UDEV_LIBS@ @DRMINTEL_LIBS@ @DRM_LIBS@ $(top_builddir)/uxa/libuxa.la
+libuxa_la_LIBADD = @UDEV_LIBS@ @DRMINTEL_LIBS@ @DRM_LIBS@
libuxa_la_SOURCES = \
brw_defines.h \
brw_structs.h \
@@ -51,6 +51,14 @@ libuxa_la_SOURCES = \
i965_video.c \
i965_render.c \
uxa_module.h \
+ uxa.c \
+ uxa.h \
+ uxa-accel.c \
+ uxa-glamor.h \
+ uxa-glyphs.c \
+ uxa-render.c \
+ uxa-priv.h \
+ uxa-unaccel.c
$(NULL)
if GLAMOR