summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3ecf7ad4..79bba832 100644
--- a/configure.ac
+++ b/configure.ac
@@ -93,6 +93,15 @@ if test x$ASM != "xno"; then
if test x$ASM = "xyes" -a x$gen4asm != "xyes"; then
AC_MSG_ERROR([intel-gen4asm support requested but not found])
fi
+ if test x$gen4asm = "xyes"; then
+ AC_MSG_CHECKING([path to use for intel-gen4asm])
+ INTEL_GEN4ASM="`pkg-config intel-gen4asm --variable=exec_prefix`/bin/intel-gen4asm"
+ if ! test -e "$INTEL_GEN4ASM"; then
+ AC_MSG_ERROR([intel-gen4asm enabled, but not found. Tried '$INTEL_GEN4ASM'.])
+ fi
+ AC_MSG_RESULT([$INTEL_GEN4ASM])
+ AC_SUBST([INTEL_GEN4ASM])
+ fi
fi
AM_CONDITIONAL(HAVE_GEN4ASM, test x$gen4asm = xyes)