summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ea7473e1..4f73ba46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -578,6 +578,17 @@ if test "x$CREATE2" = "xyes"; then
xp_msg="$xp_msg create2"
fi
+AC_ARG_ENABLE(rotation,
+ AS_HELP_STRING([--enable-rotation],
+ [Enable use of native rotations (experimental) [default=no]]),
+ [ROTATION="$enableval"],
+ [ROTATION="no"])
+AM_CONDITIONAL(USE_ROTATION, test "x$ROTATION" = "xyes")
+if test "x$ROTATION" = "xyes"; then
+ AC_DEFINE(USE_ROTATION,1,[Assume "rotation" support])
+ xp_msg="$xp_msg rotation"
+fi
+
AC_ARG_ENABLE(userptr,
AS_HELP_STRING([--enable-userptr],
[Enable use of userptr (experimental) [default=no]]),