summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0fdbc3c8..fa6439e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -344,9 +344,12 @@ if test "x$GLAMOR" != "xno"; then
if test "x$UXA" != "xyes"; then
AC_MSG_ERROR([Glamor acceleration requested but UXA is not enabled])
fi
- if ! pkg-config --exists "xorg-server >= 1.15.99.901"; then
+ if pkg-config --exists "xorg-server >= 1.15.99.901"; then
+ GLAMOR="yes (using Xorg glamor module)"
+ else
PKG_CHECK_MODULES(LIBGLAMOR, [glamor >= 0.6.0])
PKG_CHECK_MODULES(LIBGLAMOR_EGL, [glamor-egl])
+ GLAMOR="yes (using libglamor)"
fi
AC_DEFINE(USE_GLAMOR, 1, [Enable glamor acceleration])
fi