summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7476e2b5..de3a4b3e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -197,11 +197,15 @@ AC_ARG_ENABLE(udev,
if test "x$UDEV" != "xno"; then
PKG_CHECK_MODULES(UDEV, [libudev], [udev="yes"], [udev="no"])
+ AC_CHECK_HEADERS([sys/stat.h], [], [udev="no"])
if test "x$UDEV" = "xyes" -a "x$udev" != "xyes"; then
AC_MSG_ERROR([udev support requested but not found (libudev)])
fi
if test "x$udev" = "xyes"; then
AC_DEFINE(HAVE_UDEV,1,[Enable udev-based monitor hotplug detection])
+ udev_msg=" yes"
+ else
+ udev_msg=" no"
fi
fi
@@ -911,6 +915,7 @@ echo " Support for Kernel Mode Setting? $KMS"
echo " Support for legacy User Mode Setting (for i810)? $UMS"
echo " Support for Direct Rendering Infrastructure:$dri_msg"
echo " Support for Xv motion compensation (XvMC and libXvMC):$xvmc_msg"
+echo " Support for display hotplug notifications (udev):$udev_msg"
echo " Build additional tools and utilities?$tools_msg"
if test -n "$xp_msg"; then
echo " Experimental support:$xp_msg"