summaryrefslogtreecommitdiff
path: root/src/reg_dumper/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/reg_dumper/Makefile.am')
-rw-r--r--src/reg_dumper/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/reg_dumper/Makefile.am b/src/reg_dumper/Makefile.am
index b840b244..d49a59b1 100644
--- a/src/reg_dumper/Makefile.am
+++ b/src/reg_dumper/Makefile.am
@@ -1,4 +1,4 @@
-noinst_PROGRAMS = intel_reg_dumper intel_idle intel_stepping
+noinst_PROGRAMS = intel_reg_dumper intel_idle intel_stepping intel_hotplug
intel_reg_dumper_SOURCES = \
main.c \
@@ -12,9 +12,16 @@ intel_idle_SOURCES = \
xprintf.c \
../i830_debug.c
+intel_hotplug_SOURCES = \
+ hotplug.c \
+ reg_dumper.h \
+ xprintf.c \
+ ../i830_debug.c
+
intel_stepping_SOURCES = \
stepping.c
+intel_hotplug_LDADD = $(PCIACCESS_LIBS)
intel_reg_dumper_LDADD = $(PCIACCESS_LIBS)
intel_idle_LDADD = $(PCIACCESS_LIBS)
intel_stepping_LDADD = $(PCIACCESS_LIBS)