summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index f9906d44..be0b1f09 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -40,7 +40,10 @@ stress_TESTS += \
endif
check_PROGRAMS = $(stress_TESTS)
-noinst_PROGRAMS = lowlevel-blt-bench
+noinst_PROGRAMS =
+if X11_SHM
+noinst_PROGRAMS += lowlevel-blt-bench
+endif
AM_CFLAGS = @CWARNFLAGS@ $(X11_CFLAGS) $(DRM_CFLAGS)
LDADD = libtest.la $(X11_LIBS) $(DRM_LIBS) $(CLOCK_GETTIME_LIBS)