summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTilman Sauerbeck <tilman@code-monkey.de>2006-06-16 10:56:02 +0200
committerDave Airlie <airlied@linux.ie>2006-06-23 10:00:01 +1000
commit764013ec61b9043f1487513658e374569f7154a9 (patch)
tree28076b606b7c22ea1d787addb5a580773ac80fd6 /configure.ac
parent3c701d49b3eb7adb82267cec53163e475913aca3 (diff)
Use AC_CHECK_HEADER() to check for exa.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c4df2c1..ddb9dca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,8 +186,12 @@ AC_DEFINE(USE_XAA, 1, [Build support for XAA])
AC_MSG_CHECKING([whether to enable EXA support])
if test "x$EXA" = xyes; then
AC_MSG_RESULT(yes)
- AC_CHECK_FILE([${sdkdir}/exa.h],
- [have_exa_h="yes"], [have_exa_h="no"])
+
+ SAVE_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $XORG_CFLAGS"
+ AC_CHECK_HEADER(exa.h,
+ [have_exa_h="yes"], [have_exa_h="no"])
+ CPPFLAGS="$SAVE_CPPFLAGS"
else
AC_MSG_RESULT(no)
fi