summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-04-29 17:21:53 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-04-29 17:21:53 -0700
commit193744b015e8f2b8c25d90094b7f0b502bc1287b (patch)
tree674f79c50f64379f8578f93d93a78e66a14785d1 /configure.ac
parentd394e0b8269ea0a7d36ee8edb38947df170399c9 (diff)
Convert to XORG_CWARNFLAGS & XORG_CHANGELOG
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 5e8be38..7b19be0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,14 +34,15 @@ AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
+
# Checks for programs.
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_PROG_CC
-
-if test "x$GCC" = "xyes"; then
- CPPFLAGS="$CPPFLAGS -Wall"
-fi
+XORG_CWARNFLAGS
AH_TOP([#include "xorg-server.h"])
@@ -220,10 +221,11 @@ AC_SUBST([DRIVER_NAME])
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
XORG_CHECK_LINUXDOC
+XORG_CHANGELOG
AC_MSG_NOTICE(
-[Please change the Driver line in xorg.conf from "ati" to "mach64" or install]
-[the ati wrapper as well:]
+[Please change the Driver line in xorg.conf from "ati" to "mach64"]
+[ or install the ati wrapper as well:]
[ git://anongit.freedesktop.org/git/xorg/driver/xf86-video-ati]
)