summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLuc Verhaegen <libv@skynet.be>2006-03-15 00:46:33 +0000
committerLuc Verhaegen <libv@skynet.be>2006-03-15 00:46:33 +0000
commit50923b6a9325592edc8b02b17646f96b9b8c4a01 (patch)
tree4327c18885545b34bf76b5b4bd92062e6ffea0c0 /src/Makefile.am
parent74f4ed4275866475b3c182fae962df2fc0946b85 (diff)
Add some autoconf to keep this driver from building EXA when a slightly
older server with older exa is installed. The way in which this problem was treated by the actually related developers explains a lot about this driver.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d9622f9..67fff56 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -41,6 +41,10 @@ if ATIMISC_DGA
ATIMISC_DGA_SOURCES = atidga.c
endif
+if USE_EXA
+RADEON_EXA_SOURCES = radeon_exa.c
+endif
+
AM_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@
ati_drv_la_LTLIBRARIES = ati_drv.la
@@ -76,7 +80,7 @@ radeon_drv_ladir = @moduledir@/drivers
radeon_drv_la_SOURCES = \
radeon_accel.c radeon_mergedfb.c radeon_cursor.c radeon_dga.c \
radeon_driver.c radeon_video.c radeon_bios.c radeon_mm_i2c.c \
- radeon_vip.c radeon_misc.c radeon_exa.c $(RADEON_DRI_SRCS)
+ radeon_vip.c radeon_misc.c $(RADEON_DRI_SRCS) $(RADEON_EXA_SOURCES)
theatre_detect_drv_la_LTLIBRARIES = theatre_detect_drv.la
theatre_detect_drv_la_LDFLAGS = -module -avoid-version