summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDave Airlie <airlied@clockmaker.usersys.redhat.com>2007-11-20 22:33:39 +1000
committerDave Airlie <airlied@clockmaker.usersys.redhat.com>2007-11-20 22:33:39 +1000
commitc8872603454e6a4ffed9fc7d9adc2c364a429608 (patch)
tree86057a99193c04f9aaf0f2de8e2049d20efdd6b3 /src/Makefile.am
parent49055d8aff91ff12186feaf5343c8fd2f96bcba0 (diff)
radeon: restructure pci ids to avoid effort laterpci-rehash
This uses a single file with all the pciids and parameters for radeon family and setup in it. I don't run the perl script at build time to avoid a perl dependency on build but adding pci ids should be done via the csv file with openoffice or gnumeric if possible.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ff1e225..5152577 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -171,7 +171,6 @@ EXTRA_DIST = \
r128_reg.h \
r128_sarea.h \
r128_version.h \
- radeon_chipset.h \
radeon_common.h \
radeon_commonfuncs.c \
radeon_dri.h \
@@ -191,4 +190,10 @@ EXTRA_DIST = \
theatre.h \
theatre_reg.h \
atipciids.h \
- atipcirename.h
+ atipcirename.h \
+ ati_pciids_gen.h \
+ radeon_chipinfo_gen.h \
+ radeon_chipset_gen.h \
+ radeon_pci_chipset_gen.h \
+ pcidb/ati_pciids.csv \
+ pcidb/parse_pci_ids.pl