summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTilman Sauerbeck <tilman@code-monkey.de>2006-09-16 23:59:32 +0200
committerTilman Sauerbeck <tilman@code-monkey.de>2006-09-16 23:59:32 +0200
commit5830edf81a0c0119bd2486b48e56fdb9daf72586 (patch)
tree8767585e244630fb009675c91620350390e8a7f1 /Makefile.am
parent3b2a7b1faf142d4301c55b8951657e177b5ac118 (diff)
Generate ChangeLog from git.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4e76113..d05c5ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,4 +21,12 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src man util
-EXTRA_DIST = README_HALLIB mga_PInS.txt
+CLEANFILES = ChangeLog
+EXTRA_DIST = README_HALLIB mga_PInS.txt ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ git-log > ChangeLog
+
+dist-hook: ChangeLog