summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Romanick <idr@umwelt.(none)>2006-07-26 11:46:52 -0700
committerIan Romanick <idr@umwelt.(none)>2006-07-26 11:46:52 -0700
commit95e0722ff2e8878cdd6bb0e349eecab042b879db (patch)
tree03b801974e76f5feb3df4755f434952cb1faf6a8 /configure.ac
parent78c12368fa1c1985f41ce856ff453a967429870a (diff)
Current state of MGA driver modified to work with the xserver
pci-rework branch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 1ea6ce1..ec8a5ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -67,7 +67,7 @@ sdkdir=$(pkg-config --variable=sdkdir xorg-server)
# Checks for header files.
AC_HEADER_STDC
-if test "x$DRI" != xno; then
+if test "x$DRI" = xauto; then
AC_CHECK_FILE([${sdkdir}/dri.h],
[have_dri_h="yes"], [have_dri_h="no"])
AC_CHECK_FILE([${sdkdir}/sarea.h],
@@ -90,7 +90,7 @@ AC_MSG_RESULT([$DRI])
AM_CONDITIONAL(DRI, test "x$DRI" = xyes)
if test "x$DRI" = xyes; then
- PKG_CHECK_MODULES(DRI, [libdrm >= 2.0 xf86driproto])
+ PKG_CHECK_MODULES(DRI, [libdrm >= 2.0 xf86driproto glproto])
AC_DEFINE(XF86DRI,1,[Enable DRI driver support])
AC_DEFINE(XF86DRI_DEVEL,1,[Enable developmental DRI driver support])
fi