summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-26 01:18:43 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-07-26 01:18:43 +0000
commitefca764ce95094531baf14daf6e5e538cc1e9210 (patch)
tree7c221a2866e8f7a8b5d243151d790628ea6b2dfa /src/Makefile.am
parente2f4c1e72976180cfbf2486236468e25f81ca431 (diff)
"Build system for `basename $PWD | sed s/xf86-video-//`"
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am78
1 files changed, 78 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..2005436
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,78 @@
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+# FIXME: This is a little bit sick, but how else can you do it?
+noinst_LTLIBRARIES = libmga_storm8.la libmga_storm16.la libmga_storm24.la libmga_storm32.la
+libmga_storm8_la_SOURCES = mga_storm.c
+libmga_storm8_la_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@ -DPSZ=8
+
+libmga_storm16_la_SOURCES = mga_storm.c
+libmga_storm16_la_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@ -DPSZ=16
+
+libmga_storm24_la_SOURCES = mga_storm.c
+libmga_storm24_la_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@ -DPSZ=24
+
+libmga_storm32_la_SOURCES = mga_storm.c
+libmga_storm32_la_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@ -DPSZ=32
+
+# this is obnoxious:
+# -module lets us name the module exactly how we want
+# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
+# _ladir passes a dummy rpath to libtool so the thing will actually link
+# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+AM_CFLAGS = @XORG_CFLAGS@ @DRI_CFLAGS@
+mga_drv_la_LTLIBRARIES = mga_drv.la
+mga_drv_la_LDFLAGS = -module -avoid-version
+mga_drv_ladir = @moduledir@/drivers
+mga_drv_la_LIBADD = $(noinst_LTLIBRARIES)
+
+mga_drv_la_SOURCES = \
+ client.h \
+ clientlx.c \
+ mga_arc.c \
+ mga_common.h \
+ mga_dac3026.c \
+ mga_dacG.c \
+ mga_dga.c \
+ mga_dh.c \
+ mga_driver.c \
+ mga_esc.c \
+ mga_g450pll.c \
+ mga.h \
+ mga_halmod.c \
+ mga_hwcurs.c \
+ mga_macros.h \
+ mga_map.h \
+ mga_maven.h \
+ mga_merge.c \
+ mga_merge.h \
+ mgareg_flags.h \
+ mga_reg.h \
+ mga_sarea.h \
+ mga_shadow.c \
+ mga_ucode.h \
+ mga_video.c
+
+if DRI
+mga_drv_la_SOURCES +=
+ mga_dri.c \
+ mga_dri.h \
+ mga_dripriv.h
+endif