summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Plattner <aplattner@nvidia.com>2007-09-17 01:12:02 -0700
committerAaron Plattner <aplattner@nvidia.com>2007-09-17 15:41:14 -0700
commitdeff2965ef35260b4b7c4bc23718833bec7143b3 (patch)
treef77e9419473a9551dd33d266b29bd049b8674dc0 /configure.ac
parentb2db7d414400d80a5567d71eed9a7e94f1043a20 (diff)
libpciaccess support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9fdc0eb..3c99595 100644
--- a/configure.ac
+++ b/configure.ac
@@ -70,8 +70,20 @@ AC_HEADER_STDC
save_CFLAGS="$CFLAGS"
CFLAGS="$XORG_CFLAGS"
+
+# RandR 1.2
AC_CHECK_HEADER(xf86Modes.h,[BUILD_XMODES=no],[BUILD_XMODES=yes],[#include "xorg-server.h"])
+
+# PCI rework
+AC_CHECK_DECL(XSERVER_LIBPCIACCESS,
+ [XSERVER_LIBPCIACCESS=yes],[XSERVER_LIBPCIACCESS=no],
+ [#include "xorg-server.h"])
+if test "x$XSERVER_LIBPCIACCESS" = "xyes"; then
+ PKG_CHECK_MODULES(PCIACCES, [pciaccess >= 0.8.0])
+fi
+
CFLAGS="$save_CFLAGS"
+
AM_CONDITIONAL(BUILD_XMODES, test "x$BUILD_XMODES" = xyes)
if test "x$XSERVER_SOURCE" != x; then
if test -d "$XSERVER_SOURCE"; then