summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Plattner <aplattner@nvidia.com>2006-05-24 15:05:22 -0700
committerAaron Plattner <aplattner@nvidia.com>2006-05-24 15:05:22 -0700
commiteda3bac20dce2d5584ac07cc6b28a08ec55aa798 (patch)
treee63e4be10a0a33344148c52f8a3422a391f37f58 /configure.ac
parent1a40c4a79b79034d191496726a27af8b0805dba6 (diff)
Derive the module version numbers from the package version. This idea was
lifted from Michel Dänzer's similar code in xf86-video-ati. Also, make the riva and nv driver versions match.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31637e8..a44f78b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,16 @@ AC_INIT([xf86-video-nv],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
xf86-video-nv)
+AC_DEFINE_UNQUOTED([NV_MAJOR_VERSION],
+ [$(echo $PACKAGE_VERSION | sed -e 's/^\([[0-9]]\)\.[[0-9]]\.[[0-9]]/\1/')],
+ [Major version])
+AC_DEFINE_UNQUOTED([NV_MINOR_VERSION],
+ [$(echo $PACKAGE_VERSION | sed -e 's/^[[0-9]]\.\([[0-9]]\)\.[[0-9]]/\1/')],
+ [Minor version])
+AC_DEFINE_UNQUOTED([NV_PATCHLEVEL],
+ [$(echo $PACKAGE_VERSION | sed -e 's/^[[0-9]]\.[[0-9]]\.\([[0-9]]\)/\1/')],
+ [Patch version])
+
AC_CONFIG_SRCDIR([Makefile.am])
AM_CONFIG_HEADER([config.h])
AC_CONFIG_AUX_DIR(.)