summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-07-17 10:52:50 -0700
committerAaron Plattner <aplattner@nvidia.com>2010-07-19 11:34:30 -0700
commit6d2431a37ffd7a976e9046424a6c1f3c47ded2df (patch)
treec4f4a4a846ebdcb510b35a9337f69fd35d46cae1 /configure.ac
parentc383cc20dd81fa692c73968107c125787051c14d (diff)
The /compat code is no longer required.
This was used at one point in time to backport the modes code from server 1.3 to server 1.2. When the tarball was created, whatever modes code was on the developer disk was included. The server 1.2 as shipped in the tarball on the web does not contain the modes code. It was added just after and found in git branch server-1.2-branch. The modes code was initially included in version 2.0.95 and still compiles with server 1.2. As of version 2.1.9 it no longer compiles. Subsequent versions are not backward compatible and probably not meant to be. The XRandR wiki points to articles saying that XRandR 1.2 first appeared in server 1.3 and nv 2.0.95. Given that modes code in current server version does not compile with server 1.2, and that the modes code is included in version 1.3 and up, might as well stop including this modes code in the driver. This patch makes the driver requiring server 1.3 or later. This will solve the issue where "make dist" fails "out of the box" and requires manual fix-up on the build machine which is documented in the compat/README file. Signed-off-by: Gaetan Nadon <memsize@videotron.ca> Signed-off-by: Aaron Plattner <aplattner@nvidia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac47
1 files changed, 1 insertions, 46 deletions
diff --git a/configure.ac b/configure.ac
index 02f8ab3..d53c727 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,11 +55,6 @@ AC_ARG_WITH(xorg-module-dir,
[moduledir="$withval"],
[moduledir="$libdir/xorg/modules"])
-AC_ARG_WITH(xserver-source,AC_HELP_STRING([--with-xserver-source=XSERVER_SOURCE],
- [Path to X server source tree]),
- [ XSERVER_SOURCE="$withval" ],
- [ XSERVER_SOURCE="" ])
-
# Checks for extensions
XORG_DRIVER_CHECK_EXT(RANDR, randrproto)
XORG_DRIVER_CHECK_EXT(RENDER, renderproto)
@@ -67,7 +62,7 @@ XORG_DRIVER_CHECK_EXT(XV, videoproto)
XORG_DRIVER_CHECK_EXT(DPMSExtension, xextproto)
# Checks for pkg-config packages
-PKG_CHECK_MODULES(XORG, [xorg-server >= 1.2 xproto fontsproto $REQUIRED_MODULES])
+PKG_CHECK_MODULES(XORG, [xorg-server >= 1.3 xproto fontsproto $REQUIRED_MODULES])
PKG_CHECK_MODULES(XEXT, [xextproto >= 7.0.99.1],
HAVE_XEXTPROTO_71="yes"; AC_DEFINE(HAVE_XEXTPROTO_71, 1, [xextproto 7.1 available]),
HAVE_XEXTPROTO_71="no")
@@ -81,9 +76,6 @@ AC_HEADER_STDC
save_CFLAGS="$CFLAGS"
CFLAGS="$XORG_CFLAGS"
-# RandR 1.2
-AC_CHECK_HEADER(xf86Modes.h,[BUILD_XMODES=no],[BUILD_XMODES=yes],[#include "xorg-server.h"])
-
# PCI rework
AC_CHECK_DECL(XSERVER_LIBPCIACCESS,
[XSERVER_LIBPCIACCESS=yes],[XSERVER_LIBPCIACCESS=no],
@@ -94,42 +86,6 @@ fi
CFLAGS="$save_CFLAGS"
-AM_CONDITIONAL(BUILD_XMODES, test "x$BUILD_XMODES" = xyes)
-if test "x$XSERVER_SOURCE" != x; then
- if test -d "$XSERVER_SOURCE"; then
- XSERVER_SOURCE=`cd "$XSERVER_SOURCE" && pwd`
- if test -f "$XSERVER_SOURCE/hw/xfree86/modes/xf86Modes.h" -a -f "$XSERVER_SOURCE/hw/xfree86/parser/xf86Parser.h"; then
- :
- else
- AC_ERROR([Server source at $XSERVER_SOURCE doesn't have the new mode code])
- fi
- else
- AC_ERROR([Can't find xserver-source path $XSERVER_SOURCE])
- fi
-fi
-if test "x$BUILD_XMODES" = xno; then
- AC_MSG_NOTICE([X server has new mode code])
- XMODES_CFLAGS=
- parser_dir=
- modes_dir=
-else
- if test "x$XSERVER_SOURCE" = x; then
- AC_MSG_NOTICE([X server is missing new mode code and --with-xserver-source not specified, using local copy])
- AC_MSG_NOTICE([If you're building from git, please read compat/README])
- parser_dir='$(top_srcdir)/compat/parser'
- modes_dir='$(top_srcdir)/compat/modes'
- else
- AC_MSG_NOTICE([Using mode code from $XSERVER_SOURCE])
- parser_dir="$XSERVER_SOURCE/hw/xfree86/parser"
- modes_dir="$XSERVER_SOURCE/hw/xfree86/modes"
- fi
- XMODES_CFLAGS="-DXF86_MODES_RENAME -I\"$modes_dir\" -I\"$parser_dir\""
- AC_DEFINE(BUILD_XMODES, 1,[X server doesn't have built-in mode code, so we need to build it])
-fi
-AC_SUBST([XMODES_CFLAGS])
-AC_SUBST([parser_dir])
-AC_SUBST([modes_dir])
-
# Substitutions
AC_SUBST([XORG_CFLAGS])
AC_SUBST([moduledir])
@@ -141,5 +97,4 @@ AC_OUTPUT([
Makefile
src/Makefile
man/Makefile
- compat/Makefile
])