summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2008-11-14 20:36:09 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2008-11-14 20:36:09 -0200
commitcd10af22240b9df7c264b15c483d8cc4505ee359 (patch)
treeec41312655a3e06a04f2a8ba5c248e1e4e57cd35 /src/Makefile.am
parent41ef793b0ed6014ed49bef011259f977833aef5d (diff)
Only compile smi_dga.c when xf86DiDGAInit is not available.
Besides reducing driver size, this should make DGA+EXA accelerated.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 87ca97f..5170211 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -36,7 +36,6 @@ siliconmotion_drv_la_SOURCES = \
smi_xaa.c \
smi_exa.c \
smi_dac.c \
- smi_dga.c \
smi_driver.c \
smi.h \
smi_i2c.c \
@@ -52,3 +51,7 @@ siliconmotion_drv_la_SOURCES = \
smilynx.h \
smi501_crtc.c \
smi501_output.c
+
+if !XMODES
+siliconmotion_drv_la_SOURCES += smi_dga.c
+endif