summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Jackson <ajax@nwnk.net>2005-12-14 20:42:18 +0000
committerAdam Jackson <ajax@nwnk.net>2005-12-14 20:42:18 +0000
commit05917a2d030d8359b2a30f471e7100bc020d5a3f (patch)
tree5e705a3c57c3c1ef6d2d84a5484da824827ac7d4 /configure.ac
parentda7b74edb223745fc38dce3d3107a00784714f03 (diff)
Bug #4890" Include the assembly in the build (Ferris McCormick)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ffb69ce..5eee4b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,6 +37,12 @@ AM_MAINTAINER_MODE
# Checks for programs.
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
+case $host_cpu in
+ sparc*)
+ CCASFLAGS="-x assembler-with-cpp -Wa,-Av9a"
+ SPARC=yes
+esac
+AM_PROG_AS
AC_PROG_CC
AH_TOP([#include "xorg-server.h"])
@@ -94,6 +100,8 @@ if test "$DRI" = yes; then
AC_DEFINE(XF86DRI_DEVEL,1,[Enable developmental DRI driver support])
fi
+AM_CONDITIONAL(SPARC, test x$SPARC = xyes)
+
AC_SUBST([DRI_CFLAGS])
AC_SUBST([XORG_CFLAGS])
AC_SUBST([moduledir])