summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVinay Bondhugula <vinayb@vmware.com>2007-10-08 10:54:04 -0700
committerPhilip Langdale <philipl@fido2.homeip.net>2007-10-08 10:54:04 -0700
commit62d898669baccfd4c312f3ed8f228d0c3217d3c3 (patch)
treeb2bfee9fd296b8db47216765e3f82a575a87c413 /configure.ac
parent73db59fd82ced7a88f6da35d5088608e163f3d86 (diff)
Port to libpciaccess.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7b604e3..f33841b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -61,6 +61,18 @@ sdkdir=$(pkg-config --variable=sdkdir xorg-server)
# Checks for header files.
AC_HEADER_STDC
+save_CFLAGS="$CFLAGS"
+CFLAGS="$XORG_CFLAGS"
+AC_CHECK_DECL(XSERVER_LIBPCIACCESS,
+ [XSERVER_LIBPCIACCESS=yes], [XSERVER_LIBPCIACCESS=no],
+ [#include "xorg-server.h"])
+CFLAGS="$save_CFLAGS"
+
+if test x$XSERVER_LIBPCIACCESS = xyes; then
+ PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.8.0])
+fi
+
+AM_CONDITIONAL(XSERVER_LIBPCIACCESS, test "x$XSERVER_LIBPCIACCESS" = xyes)
AC_SUBST([XORG_CFLAGS])
AC_SUBST([moduledir])