summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVinay Bondhugula <vinayb@vmware.com>2008-04-22 14:18:45 -0400
committerVinay Bondhugula <vinayb@vmware.com>2008-04-22 14:18:45 -0400
commitdb027200474684c0aa4b9387f3ed53b2e5f24478 (patch)
tree4d5639a7df1f6633f247cde7a4e6f3f32ec768fd /configure.ac
parent6849c0a5fbf10722ca475d2ffcce7d0d95d2377a (diff)
More xorg and xfree86 backwards compatibility
Push most of the xorg-server version checking into the configure script. With this change, unmodified driver source compiles in the XFree86 4.3 tree.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8d20681..163a887 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,6 +58,14 @@ XORG_DRIVER_CHECK_EXT(XV, videoproto)
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.0.1 xproto fontsproto $REQUIRED_MODULES])
sdkdir=$(pkg-config --variable=sdkdir xorg-server)
+PKG_CHECK_EXISTS([xorg-server >= 1.1.0],
+ [AC_DEFINE([HAVE_XORG_SERVER_1_1_0], 1,
+ [Has version 1.1.0 or greater of the Xserver])])
+
+PKG_CHECK_EXISTS([xorg-server >= 1.0.99.901],
+ [AC_DEFINE([HAVE_XORG_SERVER_1_0_99_901], 1,
+ [Has version 1.0.99.901 or greater of the Xserver])])
+
# Checks for libraries.
# Checks for header files.