summaryrefslogtreecommitdiff
path: root/saa/Makefile.am
diff options
context:
space:
mode:
authorThomas Hellstrom <thellstrom@vmware.com>2011-06-16 15:55:07 +0200
committerThomas Hellstrom <thellstrom@vmware.com>2011-06-16 16:04:47 +0200
commit84166d4b457244bcc2f5ace63702d594d602d0c2 (patch)
tree892d9ee8de7a45b4d21505f9949a8424e3c81a44 /saa/Makefile.am
parent0142bb8d10edb153c9ce79a2ea3ff92a7fb15ac5 (diff)
vmwgfx, saa: Initial import
This imports the vmwgfx driver, based on the Gallium3D Xorg state tracker, as well as the saa library. A "Shadow Acceleration Architecture", which is optimized for the case where transfers between system (shadow) and hw memory is very costly. Signed-off-by: Thomas Hellstrom <thellstrom@vmware.com>
Diffstat (limited to 'saa/Makefile.am')
-rw-r--r--saa/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/saa/Makefile.am b/saa/Makefile.am
new file mode 100644
index 0000000..4f56d3f
--- /dev/null
+++ b/saa/Makefile.am
@@ -0,0 +1,13 @@
+libsaa_la_LTLIBRARIES = libsaa.la
+libsaa_ladir = @libdir@
+
+libsaa_la_CFLAGS = $(CWARNFLAGS) $(XORG_CFLAGS)
+libsaa_la_SOURCES = \
+ saa.c \
+ saa_pixmap.c \
+ saa_unaccel.c \
+ saa_priv.h \
+ saa_render.c \
+ saa_accel.c \
+ saa.h
+