summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-04-05 14:28:06 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-04-05 14:28:06 -0700
commit2179b2d467d69e45559b8e4f161a904a21f05321 (patch)
tree1c29081ef1bba8766b50b94899273ebb4cd74873 /Makefile.am
parent6b361c028b5ad931b61df86fae570f3ef9f41c15 (diff)
Add hooks for checking source code with lint/sparse/etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d3dd678..2d72364 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,3 +10,8 @@ ChangeLog:
(GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
dist-hook: ChangeLog
+
+if LINT
+lint:
+ (cd src && $(MAKE) $(MFLAGS) lint)
+endif LINT