summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu.herrb@laas.fr>2013-08-29 22:18:14 +0200
committerMatthieu Herrb <matthieu.herrb@laas.fr>2013-09-12 21:20:24 +0200
commit80f62c54fbd50a3bbdf9c37258525098c9117830 (patch)
tree8fab366d8c45a27832c44585fa0b086907964281 /configure.ac
parent2312ee00402088307e69589c3d12529b5232df66 (diff)
Use arc4random when available to produce the auth cookie.
arc4random() and associated functions can be found in libbsd on GNU/Linux systems. Signed-off-by: Matthieu Herrb <matthieu.herrb@laas.fr> Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 81809ce..701b6c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,7 +37,8 @@ XTRANS_CONNECTION_FLAGS
AC_DEFINE(ICE_t, 1, [Xtrans transport type])
# Checks for library functions.
-AC_CHECK_FUNCS([asprintf])
+AC_CHECK_LIB([bsd], [arc4random_buf])
+AC_CHECK_FUNCS([asprintf arc4random_buf])
# Allow checking code with lint, sparse, etc.
XORG_WITH_LINT