summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-17 20:52:35 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-17 20:52:35 +0000
commit9dd90f8f8e29bb1dd6fe84b4b1d2d75ef91bc336 (patch)
tree50a571e47266ea64884c87561775450d4cd0bac8 /src/Makefile.am
parentd1cfe2a6d4a392f64b6b9d9255ec329fb2a6a39a (diff)
Add ICE directory + build system.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..6944647
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,40 @@
+lib_LTLIBRARIES=libICE.la
+
+AM_CFLAGS= -I${top_srcdir}/include $(ICE_CFLAGS) $(XTRANS_CFLAGS)
+
+libICE_la_LDFLAGS = -version-number 6:4:1 -no-undefined
+
+libICE_la_LIBADD = $(ICE_LIBS) $(XTRANS_LIBS)
+
+libICE_la_SOURCES = \
+ ICElibint.h \
+ accept.c \
+ authutil.c \
+ connect.c \
+ error.c \
+ getauth.c \
+ globals.h \
+ iceauth.c \
+ icetrans.c \
+ listen.c \
+ listenwk.c \
+ locking.c \
+ misc.c \
+ ping.c \
+ process.c \
+ protosetup.c \
+ register.c \
+ replywait.c \
+ setauth.c \
+ shutdown.c \
+ watch.c
+
+iceincludedir=$(includedir)/X11/ICE
+iceinclude_HEADERS=\
+ $(top_srcdir)/include/X11/ICE/ICE.h \
+ $(top_srcdir)/include/X11/ICE/ICEconn.h \
+ $(top_srcdir)/include/X11/ICE/ICElib.h \
+ $(top_srcdir)/include/X11/ICE/ICEmsg.h \
+ $(top_srcdir)/include/X11/ICE/ICEproto.h \
+ $(top_srcdir)/include/X11/ICE/ICEutil.h
+