summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 918e129..de0726e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,17 +36,19 @@ AC_DEFINE(ICE_t, 1, [Xtrans transport type])
# Checks for header files.
AC_HEADER_STDC
+# Require xorg-macros at least 1.2.1
+XORG_MACROS_VERSION([1.2.1])
+m4_ifndef([XORG_MACROS_VERSION],
+ [AC_FATAL([must install xorg-macros 1.2.1 or later before running autoconf/autogen])])
+
dnl Allow checking code with lint, sparse, etc.
XORG_WITH_LINT
XORG_LINT_LIBRARY([ICE])
LINT_FLAGS="${LINT_FLAGS} ${ICE_CFLAGS} ${XTRANS_CFLAGS}"
-if test "x$GCC" = "xyes"; then
- GCC_WARNINGS="-Wall -Wpointer-arith -Wstrict-prototypes \
- -Wmissing-prototypes -Wmissing-declarations \
- -Wnested-externs -fno-strict-aliasing"
- CFLAGS="$GCC_WARNINGS $CFLAGS"
-fi
+XORG_CHANGELOG
+
+XORG_CWARNFLAGS
XORG_RELEASE_VERSION