summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-17 21:25:16 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-17 21:25:16 +0000
commit0b4b811191a1e74356b7ff78a09107e29a7ef695 (patch)
tree768103a94f00e51c47c5c69eeaa0a124cf9368ac /configure.ac
parent5004ef0b757c1cd7e4ceaa1759914f938d5ea295 (diff)
- Conditionally include config.h in xc/lib/SMXORG-6_8_99_9XORG-6_8_99_8XORG-6_8_99_10
- Add libSM to symlink.sh - Add SM build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..89dba99
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,40 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.57)
+AC_INIT([libSM],
+ 6.0.4,
+ [keithp@keithp.com],
+ libSM)
+
+AC_CONFIG_SRCDIR([Makefile.am])
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_LIBTOOL
+AC_PROG_CC
+
+# Checks for pkg-config packages
+PKG_CHECK_MODULES(SM, ice xproto xtrans)
+AC_SUBST(SM_CFLAGS)
+AC_SUBST(SM_LIBS)
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_HEADER_STDC
+
+if test "x$GCC" = "xyes"; then
+ GCC_WARNINGS="-Wall -Wpointer-arith -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations \
+ -Wnested-externs -fno-strict-aliasing"
+ CFLAGS="$GCC_WARNINGS $CFLAGS"
+fi
+
+AC_OUTPUT([Makefile
+ src/Makefile
+ sm.pc])