summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2008-06-24 13:11:42 -0400
committerAdam Jackson <ajax@redhat.com>2008-06-24 13:11:42 -0400
commit6702e2a15992f4cb85dfa7ac8214125eb0a2bb2d (patch)
treeb880a0d10278ee1c6f2b8d233e3357b8f4bce70b /configure.ac
parent2a827d26cfb10dc6b1203b77c0cc91dc838d97a3 (diff)
Bug #14949: Don't use gethostbyname() for client IDs.
gethostbyname() will hit the network, which leads to DNS timeouts, which leads to fail. Just use UUIDs.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4a72c19..db2f3b9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,13 @@ AC_HEADER_STDC
# Needed to check for TCP & IPv6 support and set flags appropriately
XTRANS_CONNECTION_FLAGS
+AC_ARG_WITH(libuuid, AC_HELP_STRING([--with-libuuid], [Build with libuuid support for client IDs]))
+AM_CONDITIONAL(WITH_LIBUUID, test x"$with_libuuid" != xno)
+
+if test x"$with_uuid" != xno; then
+ PKG_CHECK_MODULES(LIBUUID, uuid)
+fi
+
if test "x$GCC" = "xyes"; then
GCC_WARNINGS="-Wall -Wpointer-arith -Wstrict-prototypes \
-Wmissing-prototypes -Wmissing-declarations \