summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDan Williams <dcbw@redhat.com>2008-06-24 13:11:42 -0400
committerAdam Jackson <ajax@redhat.com>2008-06-24 13:11:42 -0400
commit6702e2a15992f4cb85dfa7ac8214125eb0a2bb2d (patch)
treeb880a0d10278ee1c6f2b8d233e3357b8f4bce70b /src/Makefile.am
parent2a827d26cfb10dc6b1203b77c0cc91dc838d97a3 (diff)
Bug #14949: Don't use gethostbyname() for client IDs.
gethostbyname() will hit the network, which leads to DNS timeouts, which leads to fail. Just use UUIDs.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b44e623..dbfef37 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -2,10 +2,18 @@ lib_LTLIBRARIES=libSM.la
AM_CFLAGS= -I${top_srcdir}/include $(SM_CFLAGS) $(XTRANS_CFLAGS)
+if WITH_LIBUUID
+AM_CFLAGS += $(LIBUUID_CFLAGS) -DHAVE_LIBUUID
+endif
+
libSM_la_LDFLAGS = -version-number 6:0:0 -no-undefined
libSM_la_LIBADD = $(SM_LIBS) $(XTRANS_LIBS)
+if WITH_LIBUUID
+libSM_la_LIBADD += $(LIBUUID_LIBS)
+endif
+
libSM_la_SOURCES = \
SMlibint.h \
globals.h \