summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu.herrb@laas.fr>2006-07-29 21:30:25 +0200
committerMatthieu Herrb <matthieu@reactor.herrb.com>2006-07-29 21:30:25 +0200
commitbe1d6f234b8366be9cc81bbc6e1774243102cb6d (patch)
treecf40a58779dac3f83db31e490314c64c43e72144 /Makefile.am
parent27ce5ef4924cd162f9313d2c444d2830dc71e9ae (diff)
Remove ChangeLog. Add a rule in Makefile.am to generate it using git-log.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e19f5d..2e75eea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,3 +26,9 @@ pkgconfig_DATA = xscrnsaver.pc
EXTRA_DIST = xscrnsaver.pc.in autogen.sh
+.PHONY: ChangeLog
+
+ChangeLog:
+ GIT_DIR=${srcdir}/.git git-log --name-only > ChangeLog
+
+dist-hook: ChangeLog