summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2008-03-17 18:05:32 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2008-03-17 18:15:29 -0700
commitb805b9ebb2f981a507d16fc5524f573b8187e5f1 (patch)
treecc8adc433da8ab6005ffd9b33cde08500a13de50 /Makefile.am
parentae5c253a13cbb408cb41e173bffb993ec6aa6310 (diff)
Add hooks to check code with sparse/lint/etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 77a88c8..725a8e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -34,3 +34,9 @@ ChangeLog:
(GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
dist-hook: ChangeLog
+
+if LINT
+# Check source code with tools like lint & sparse
+lint:
+ (cd src && $(MAKE) $(MFLAGS) lint)
+endif LINT