summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-07-13 17:01:49 -0700
committerAlan Coopersmith <alanc@alf.(none)>2006-07-13 17:01:49 -0700
commit881115413a7c157c9aab8fba39c8929692baaacc (patch)
treeb9fb27b5548b37cf504a4ca7bf48af9ceb542a94 /Makefile.am
parentf25155b03b9fa866d522714ad64e92bf7f2b95fa (diff)
Generate lint library for checking programs that call functions in libXau
(Disabled by default, enable with --enable-lint-library)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am15
1 files changed, 13 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 9c8bc12..ac78667 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,11 +36,22 @@ Autest_SOURCES=Autest.c
Autest_LDADD=libXau.la
if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS)
+
lint:
- $(LINT) $(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
- $(AM_CPPFLAGS) $(CPPFLAGS) $(libXau_la_SOURCES)
+ $(LINT) $(ALL_LINT_FLAGS) $(libXau_la_SOURCES)
endif LINT
+if MAKE_LINT_LIB
+lintlibdir = $(libdir)
+
+lintlib_DATA = $(LINTLIB)
+
+$(LINTLIB): $(libXau_la_SOURCES)
+ $(LINT) -y -oXau -x $(ALL_LINT_FLAGS) $(libXau_la_SOURCES)
+endif MAKE_LINT_LIB
+
LIB_MAN_DIR_SUFFIX = $(LIB_MAN_DIR:@mandir@/man%=%)
libmandir = $(LIB_MAN_DIR)