summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2006-06-28 22:53:36 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2006-06-28 22:53:36 +0000
commit385d7fa4f151425539d613c9665b5e862f3ef614 (patch)
tree39c7e788d6ce22e6f092e5b6a052a999a48bc37f /Makefile.am
parent21ea069c9078edd386e96e038e1a71e041e32cf5 (diff)
Add "--with-lint" configure flag and "make lint" Makefile target to check
source code with lint, sparse or similar tools.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 03bf6ac..6008b3d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,12 @@ TESTS=Autest
Autest_SOURCES=Autest.c
Autest_LDADD=libXau.la
+if LINT
+lint:
+ $(LINT) $(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS) $(libXau_la_SOURCES)
+endif LINT
+
LIB_MAN_DIR_SUFFIX = $(LIB_MAN_DIR:@mandir@/man%=%)
libmandir = $(LIB_MAN_DIR)